Technical issues
Incident Report for Exscudo exchange
Resolved
This incident has been resolved.
Posted Jun 25, 2021 - 11:31 UTC
Identified
Techical issues with the exchange. The maintenance is started and will last until recovery.

We apologize for the inconvenience. Our engineers work hard on the fastest fix.
Posted Jun 24, 2021 - 13:16 UTC
This incident affected: Digital Assets Gateways (Bitcoin (BTC), Bitcoin Cash (BCH), Bitcoin Gold (BTG), Bitcoin SV (BSV), Cardano (ADA), Cosmos (ATOM), Dash (DASH), Dogecoin (DOGE), Eon (EON), Ethereum classic (ETC), Ethereum (ETH), Electroneum (ETN), Litecoin (LTC), Monero (XMR), NavCoin (NAV), NEM (XEM), Neo (NEO), Qtum (QTUM), Ripple (XRP), Stellar (XLM), TRON (TRX), Zcash (ZEC)), Ethereum Tokens Gateways (CEDEX Coin (CEDEX), crypto.tickets (CTKT), DAI (DAI), Itchiro Games (JEM), MILK2, OmiseGO (OMG), Robonomics (XRT), SHAKE, Tether EUR (EURT), Tether USD (USDT), TrueUSD (TUSD), Uniswap (UNI), Universa (UTNP), USD Coin (USDC), Wrapped Bitcoin (WBTC), Yearn Finance Limited Edition (YFLTD), Yearn Finance Platinum (YFPL), YFI Credits Group (YFICG)), Fiat Currency Gateways (Cards (EUR), Cards (RUB), SEPA (EUR)), Neo Tokens Gateways (Flamingo (FLM), NKN (NKN), Qlink Token (QLC)), and Web API, Web Cabinet.